Frontpage   Releases   Forum   Documents   Downloads   Links   Join Us!   Disclaimer   Contact Us


Author Topic: Performanceprobleme und mat-manager  (Read 3017 times)

0 Members and 1 Guest are viewing this topic.

Offline ElmarBoehl

  • Member
  • ***
Performanceprobleme und mat-manager
« on: October 10, 2010, 10:29:23 AM »
hi liebe fliegergemeinde!!

meine systemdaten sind

AS ROCK770 Extreme3
AMD Phenom II X4 Quad-C 945 3.0 GHz 8 MB
Kingston 2c2048 MBDDR3/1333HyperX CL9
nvidiaGTX 460 1024 MB
MS-WIndows 7 Home Premium 64 Bit SB

probleme

1) mat - manager läuft nicht, ist das eine rein 32 bittaugliches tool?

2) ruckeln bei großen bomberpulks (beispiel- Boeckes geniale "defense of the reich 43-45 kampagne!!!! : Angreifen gegen 39 Bomber in großer höhe mit vielen kondensstreifen, da friert es fast ein.

Ich habe 2 varianten ausprobiert:
1. in einem auf meinem rechner sogen. programme/x86- ordner eine 32 bit variante von IL-2 UP 2.01, bislang ohne  mat manager installiert   und

2. im regulären programme-ordner eine 64 bit version + 00_4GB_CLient_Executable aktiviert mit JSGME.-ohne mat manager, weil da kamen beim versuch nur noch fehlermeldungen vom matmanager und da hab ich ihn wieder runtergeschmissen.

habe mich bei beiden versionen mit den üblichen mitteln, also conf.ini ändern ( auch VideoSetupId=17 und ProcessAffinityMask=15, abschwächen der audioperformance im spiel selber versucht, irgendwie nicht befiedigend.
Die wassedarstellung im 32 bit modus ist deutlich geiler mit glitzer und transparenter, 64 bit immer "ölig"...

Lange rede, kurzer sinn:

32 bit oder 64 bit, was ist letztlich von eurer seite zu empfehlen? oder liegts daran garnicht?
doof ist dabei, dass ich eigentlich gehofft hatte durch meine letzte aufrüstaktion derartige problemchen aus der welt geschafft und  in der" englischen einstellung", also "alles rein" keine probleme mehr zu haben.

wie ist eure meinung??
danke für eure mühen und ein schönes restwochenende!!

LG elmar

Offline ~NB~Eagle

  • Beta-testers
  • IL2 Addict
  • *
Re: Performanceprobleme und mat-manager
« Reply #1 on: October 13, 2010, 01:18:26 PM »
zu Problemen:
zu 1.)
- durchaus möglich, das der Mat-Manager nur 32bit kompatibel ist

zu 2.)
 - es gibt viele grafische Faktoren, die die Performance bei IL2 eines noch so gut zusammengestellten Rechners in die Knie zwingen, aber meist sind es die Kombinationen aus einigen, wie z.B.:
- Sichtweite
- Größe der Karte / Anzahl der Objekte darauf
- Qualität der Wasserdarstellung / Umgebung
- Anzahl der Flugzeuge / der Flak
- Anzahl und Qualität der Effekte
- Wolkenqualität und Quantität / Wetter

bezogen auf die Einstellungen der Grafikkarte solltest du folgende Dinge überprüfen:
- Auflösung
- Antialaising (AA)
- Anisotroper Filter (AF)

zu den Varianten:
zu 1.) und 2.)
- für Windows Vista / 7 es ist erforderlich, die Installation von IL2 in einen eigenen Ordner durchzuführen und nicht in die Programmpfade zu installieren. Des weiteren solltest du auch noch andere  Exe_...MB austesten (auch wenn die 4GB für 64bit ausgeschrieben ist). Probier mal die Exe_512MB aus.

Fazit:

IL2 ist ein Spiel von 2001 in einer Neuauflage und wurde mit Mods aufgebessert und verfeinert (dank der vielen Modder).  Nichts desto trotz bleibt es ein relativ "altes" Spiel und man wird immer mit Kompromissen leben müssen. IL2 wurde für 32bit und eine Auflösung von 1024x768 konzipiert was damals dem generellen Maßstab entsprach und teilweise auch neue gesetzt hat. Natürlich kann man IL2 auch mit 64bit und höheren Auflösungen schnell und flüssig spielen, aber es erfordert ein wenig Geduld und umso mehr Tests.


Edit: ...hast du an die Aktivierung der Unterstützung für Mehrkern-Systeme (multicore-systems) gedacht? Wenn nicht schau mal hier => http://www.mission4today.com/index.php?name=Knowledge_Base&op=show&kid=422

Offline ElmarBoehl

  • Member
  • ***
Re: Performanceprobleme und mat-manager
« Reply #2 on: October 14, 2010, 09:19:35 AM »
ok, dankefür deine antwort!!!
daraus ergeben sich 2 kleine fragen :-[

1. habe mein spiel momentan unter ubisoft/IL-2 Sturmovik 1946 installiert. meinst du ich sollte das ganz woanders unterbringen, also garnicht unter "programme", wg Win7 mein´ich?

2. was muss ich unter
- Auflösung
- Antialaising (AA)
- Anisotroper Filter (AF) denn beachten und was erreicht man mit welcher einstellung ?? habe im moment alles auf "globale einstellung" stehen...

danke im voaraus

elmar

Offline ~NB~Eagle

  • Beta-testers
  • IL2 Addict
  • *
Re: Performanceprobleme und mat-manager
« Reply #3 on: October 14, 2010, 10:07:45 AM »
zu 1.) ja, auf keinen Fall in die Programmordner installieren. (gilt für WinVista und Win7)

zu 2.) du sollst einfach schauen, mit welchen Einstellungen du spielst und diese dann entsprechend anpassen, bzw. so verändern, daß dein Spiel wieder flüssig läuft.

im groben gilt, das Spiel sollte flüssiger laufen:

- je geringer die Auflösung
- je kleiner die Kantenglättungeinstellung (Antialaising: http://de.wikipedia.org/wiki/Antialiasing_%28Computergrafik%29),... allerdings brauchst du bei deinen Systemeigenschaften natürlich nicht vollends drauf verzichten.
- je optimaler die Texturfilterung (Anisotropes Filtern: http://de.wikipedia.org/wiki/Anisotropes_Filtern) an dein System/Grafikkarte angepasst ist => bilineare / trilineare Filterung usw.

Offline ElmarBoehl

  • Member
  • ***
Re: Performanceprobleme und mat-manager
« Reply #4 on: October 15, 2010, 02:23:52 PM »
...hm, bist du sicher, dass das mit dem programmeordner seine richtigkeit hat? ich habe mir das komplette verzeichnis von IL-2Sturmovik1946 aus dem 64bit-programmeordner in den Benutzerordner reinkopiert und der nimmt keine änderungen mehr an. will sagen, spiel kehrt immer wieder zu einem bestimmten benutzer zurück und nicht zu dem letzten, den ich gespielt habe. außerdem werden neue kampagnen nicht mehr angenommen-in meinem fall die dynamische RV 43-45  modded von Boelcke ( mal wieder). die war nämlich nicht mit rüberkopiert worden. ...kapiere ich nicht. liegt das an dem beutzerordner? ist der irgendwie besonders geschützt?
ich versuchs jetz nochmal und kreiere einen neuen ordner, den ich außerhalb "programme" setze...

Offline ~NB~Eagle

  • Beta-testers
  • IL2 Addict
  • *
Re: Performanceprobleme und mat-manager
« Reply #5 on: October 15, 2010, 02:37:07 PM »
Das mit den Programmordnern hat seine Richtigkeit. IL2 sollte dort auf keinen Fall installiert werden. Außerdem musst du IL2 mit Administratorrechten installieren. Ich denke, das es bei dir eher daran liegt...

bei der Installation rechtsklick auf die Setup => als Administrator ausführen / installieren ...

Offline ElmarBoehl

  • Member
  • ***
Re: Performanceprobleme und mat-manager
« Reply #6 on: October 17, 2010, 09:34:53 AM »
hallo eagle!!
habe das soweit alles gemacht und teste mich gerade durch die grakaeinstellungen durch ( antialaising etc.)...der erste eindruck ist bei mir, seit ich eben nicht mehr im programmeordner installiert habe, läuft das spiel flüssiger, die texturen-bei unveränderten einstellungen zu vorher- sehen an land spitze aus, das wasser aber ist, gelinde gesagt, eine katastrophe-matt, kaum lichtreflexe ...liegt das an den 64 bit?? wie gesagt, eine 2. IL-2 installation bei mir im x86-programmeordener, wo wohl die 32 bit betriebe laufen zeigt die gewünschten ergebnisse, zumindest bei den texturen, allerdings etwas ruckeliger.
muss ich da jetzt mit leben, also 64bit mit kacke wasser( sagt man nicht, weiss ich )und flüssig oder 32bit und ruckel( bei viel flak/ große bomberstöme) oder weiter ausprobieren? letzte  frage dürfte sich erübrigen aber ausprobieren kostet unsummen an zeit und evtl gibts da ja ein paar erfahrungswerte eurer/deinerseits, die mir das was abkürzen hälfen?

LG elmar

Offline ~NB~Eagle

  • Beta-testers
  • IL2 Addict
  • *
Re: Performanceprobleme und mat-manager
« Reply #7 on: October 17, 2010, 02:07:10 PM »
... das wasser aber ist, gelinde gesagt, eine katastrophe-matt, kaum lichtreflexe ...

Hast du auch die Einstellung des Wassers in der conf.ini angepasst? Water=3 (oder 4)
http://wiki.sturmovik.de/index.php?title=Conf.ini
Ausserdem sollten die Einstellung (im Spiel) auf "Perfekt" stehen, dafür muss der HardwareShader=1 aktiviert sein.
http://wiki.sturmovik.de/index.php?title=Conf.ini#.5BRender_OpenGL.5D

Offline ElmarBoehl

  • Member
  • ***
Re: Performanceprobleme und mat-manager
« Reply #8 on: October 17, 2010, 05:44:31 PM »
jaja, alles gemacht... ist mir echt ein rätsel :suicide:

wie gesagt, im 32bit x86/programmeordner ist die performance (wasser) am besten, 64bit-anwendung+00_4GB...im JSGME noch akzeptabel und in dem empfohlenen ordner außerhalb programme ( 64 bit?) echt übel....alle einstellungen( conf.ini, setup usw) sind exakt die selben, weil ich den IL-2 ordner einfach aus einem backup von externer festplatte wieder auf den rechner gespielt habe, nachdem ich meinen rechner auf 64bit hochgerüstet hatte ( siehe systeminfo am anfang). das komische ist ja , dass es in der "schwächeren" variante im x86-ordner, der, so weit ich weiss alle 32 bit-anwendungen erledigt, also programme, die nur 32 brauchen/können, mit abstand das beste ergebnis optisch kriege-insgesamt leistungsmäßig natürlich nicht. doof finde ich das vor allem, weil die aufrüstaktion ein paar taler gekostet hat und jetzt bin ich eigentlich nur zu 70 % zufrieden. UND kann mir echt nicht erklären woher dieser optische mangel kommt. das muss irgendein kleiner kleckermist sein...oder behindern sich sozusagen die 3 parallelinstallationen ( so zum rumprobiern und vergleichen) ??

Offline ~NB~Eagle

  • Beta-testers
  • IL2 Addict
  • *
Re: Performanceprobleme und mat-manager
« Reply #9 on: October 18, 2010, 11:27:30 AM »
...das komische ist ja , dass es in der "schwächeren" variante im x86-ordner........mit abstand das beste ergebnis optisch kriege-insgesamt leistungsmäßig natürlich nicht....
Vielleicht liegt es daran, daß du dein IL2 jedesmal als backup von der externen Platte holst.
Hast du mal versucht IL2 komplett NEU (außerhalb der Programmordner) zu installieren?

Offline ElmarBoehl

  • Member
  • ***
Re: Performanceprobleme und mat-manager
« Reply #10 on: October 18, 2010, 02:46:40 PM »
nee, habe ich noch nicht versucht, weil das doch recht aufwendig ist zeitlich, bis da so alles auf UP 2.01 standard ist...außerdem weiss ich garnicht mehr genau, wie das alles nacheinander installiert werden muss-ist ja doch schon was her, dass ich das angegangen bin seinerzeit :mda:....so mit 4.07 natur + patches ( muss mir da erst noch mal alle backups zusammensuchen) + UP 2.0 , UP2.01. mach ich  mal an einem verregneten sonntag nachmittag. warum ist das denn so, dass man den programme-pfad meiden sollte bei win7?

LG elmar

Offline ~NB~Eagle

  • Beta-testers
  • IL2 Addict
  • *
Re: Performanceprobleme und mat-manager
« Reply #11 on: October 18, 2010, 03:27:10 PM »
...warum ist das denn so, dass man den programme-pfad meiden sollte bei win7?...

Das hat glaube ich etwas mit der Rechteverwaltung zu tun.

zur Installation:

=> IL2 1946 installieren
=> Patch 4.08m installieren
=> Patch 4.09m installieren
=> UP 2.01 installieren

(siehe auch hier => http://ultrapack.il2war.com/page/readme)

Offline ElmarBoehl

  • Member
  • ***
Re: Performanceprobleme und mat-manager
« Reply #12 on: October 18, 2010, 05:30:17 PM »
 :clapping: danke!!!! 8)

Offline JG54_Emil

  • IL2 Addict
  • *****
    • JG54 "Grünherz"
Re: Performanceprobleme und mat-manager
« Reply #13 on: October 18, 2010, 06:14:45 PM »
Ist einfacher den Pfad zu vermeiden als danach zu suchen wo das problem liegt.

Mit Adminrechten ist das Problem auch zu lösen.
Dazu müsstest du allerdings bei jeder Gelegeheit (patch Update etc.) die Adminrechte neu vergeben, sonst schleicht sich ein Fehler ein.

Also lieber gleich aus dem Prgramme ordner draußen lassen.
JG54 is recruiting!
Check our Website:
www.IIJG54Gruenherz.org
www.Gruenherzjaeger.de

Offline ElmarBoehl

  • Member
  • ***
Re: Performanceprobleme und mat-manager
« Reply #14 on: October 19, 2010, 12:55:37 PM »
aaaaaaalso...erst mal vielen dank für eure hilfe!!!
nu isses so, dass ich eine neuinstallation versucht habe und es klappt nicht.
meine schritte waren: 1. bisherigen ordnern, die IL-2 enthielten namensänderungen verpasst, damit die installation überhaupt losgehen kann.
2. Installations-cd rein und per rechtsklick als admin gestartet.

jetzt sollte alles seinen gang gehen...tuts aber nicht, weil alles eeeeeendlos lange dauert und danach beim probedurchlauf MIT cd, weil ist ja noch kein keks drin startet das spiel erst garnicht...
habe auf meinem alten rechner das selbe getestet, weil ich dachte cd kaputt...reibungslos und schnell installiert, wie gewohnt.
auf meinem neuen rechner ein anderes spiel als test installiert-von wegen laufwerk evtl im eimer-reibungslos...
muss ich etwa doch alle Il-2 installationen, vom rechner runterholen??? und dann als pfad z.b. ubisoft/IL-2Sturmovik1946 angeben-also besagten programmeordner meiden?? ich kapiers nicht, weil ich habe das immer wie oben beschr. gemacht und das gab nie probleme.
ich hatte mir schon vor 6 monaten mal ne kopie von Il-21946 ungemodded als backup extern angelegt, die kann ich nicht etwa einfach da rüberkopieren??

uiui...aber solche probleme sind mir bislang fremd gewesen und jetzt mit dem 64bit rechner tun sich doch  :suicide_fool:auf einmal solche baustellen auf...oder soll ich alles auf programme x86, also 32bit laufen lassen, wobei dabei ja auch die win7 problematik bestehen bleibt...

help, komm mir total anfängerhaft vor, sorry

LG elmar :suicide_fool:

Offline ~NB~Eagle

  • Beta-testers
  • IL2 Addict
  • *
Re: Performanceprobleme und mat-manager
« Reply #15 on: October 19, 2010, 02:30:23 PM »
...meine schritte waren: 1. bisherigen ordnern, die IL-2 enthielten namensänderungen verpasst, damit die installation überhaupt losgehen kann.
2. Installations-cd rein und per rechtsklick als admin gestartet.

jetzt sollte alles seinen gang gehen...tuts aber nicht, weil alles eeeeeendlos lange dauert und danach beim probedurchlauf MIT cd, weil ist ja noch kein keks drin startet das spiel erst garnicht...
habe auf meinem alten rechner das selbe getestet, weil ich dachte cd kaputt...reibungslos und schnell installiert, wie gewohnt...
zu 1.) ...Beim umbennen der Ordner kann wieder ein Rechteproblem aufgetreten sein.
zu 2.) ...Hattest du auch die IL2setup.exe vor dem ersten Start ausgeführt? Hattest du 4.08m und 4.09m bereits installiert? Wenn nicht, dann teste es nach dem Patch 4.08m bzw. 4.09m...

Offline zephyr

  • Junior Member
  • **
Re: Performanceprobleme und mat-manager
« Reply #16 on: September 30, 2011, 05:20:08 PM »
Hallo zusammen,

habe unter UP 3.0 RC4 das Problem, dass der Rechner oder die GraKa beim Fliegen von Jets in der Cockpitsicht wohl extrem überlastet ist ... macht nur ganz langsam wenige "Zucker" nacheinander, obwohl das Spiel im Hintergrund wohl in "Normalzeit" weiterlauft. Bei Außenansicht (mit F2 oder F8 ) ist alles normal. Habe mehrere Jets getestet ... immer das gleiche.

Bei Propellermaschinen ist dieses Problem bisher noch nicht aufgetreten.

Hat jemand eine Idee, woran das liegen könnte?

Offline ~NB~Eagle

  • Beta-testers
  • IL2 Addict
  • *
Re: Performanceprobleme und mat-manager
« Reply #17 on: October 01, 2011, 02:05:45 AM »
Die Jets fliegen schneller, dadurch muss deine Umgebung schneller "aufgebaut" werden und dein PC muss mehr leisten. Oder besteht das Problem auch, wenn der Jet am Boden steht?
Versuch mal die Performance zu verbessern, indem du an den Grafikeinstellungen drehst.

 

Powered by EzPortal